si.Mail conflicts with HP Scanning Soft

Report bugs here
Sergei Sarbash
Posts: 8
Joined: 13 Aug 2003 13:10
Location: Naberezhnye Chelny city, Russia
Contact:

si.Mail conflicts with HP Scanning Soft

Postby Sergei Sarbash » 23 Nov 2007 18:14

si.Mail 0.9.8.1392
When scanning is started in the scanning program constantly appears error messages about script errors. It uses Internet Explorer inside itself. It can't run scripts when si.Mail is loaded.

Sorry for English, it isn't my native...

mvrhov
Site Admin
Site Admin
Posts: 884
Joined: 12 Jul 2003 21:15
Location: Kranj, Slovenia
Contact:

Re: si.Mail conflicts with HP Scanning Soft

Postby mvrhov » 24 Nov 2007 09:46

Hi Sergei,
that's very interesting as si.Mail sets restrictions only for itself and not for all applications. Can you tell me the name of that scan application so I can try to simulate that in VMWare?

Regards,
Miha

Sergei Sarbash
Posts: 8
Joined: 13 Aug 2003 13:10
Location: Naberezhnye Chelny city, Russia
Contact:

Re: si.Mail conflicts with HP Scanning Soft

Postby Sergei Sarbash » 24 Nov 2007 19:25

Hello Miha,

I'm amazing myself about this!
This is a bloatware from HP for their HP Scanjet 4070 Scanner... It's a whole bundle of misc progz for customer, main is called "HP Director". I just use the TWAIN driver for our scanner from Photoshop CS3. When TWAIN driver loaded it's UI is appears. It's so strange that it conflicts with si.Mail. It has written as dotnet app and uses Internet Explorer Engine somehow to running some scripts. Although errors still happen it works and scanning works but with many annoying error messages during the process. As far as I understand, it uses javascript for some purposes and if si.Mail is loaded when I call TWAIN scanning program it becomes buggy about scripts. However, other apps work just fine. How does this scanning program interacts with si.Mail? No answer...


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest