crash when closing si.mail

Report bugs here
rolf
Posts: 83
Joined: 23 Sep 2004 16:19
Location: Denmark

crash when closing si.mail

Postby rolf » 16 Apr 2008 08:55

Hi Miha,

si.mail (version - 1550, but happens with 1530 too) has started to show a somewhat strange behavior:

I have five different accounts, which are checked regularly. One particular shows regularly the following error, when viewing mail (click on INBOX, click on any mail shown there):

"Message IDs (from file 1xxx [four digits]and from message file = 8xxxx [19 digits]) does not match. Loading anyway".

When I click OK, the massage is displayed.

Furthermore,when closing si.mail, I regularly get an error (sent a bug report today).

And a last thing - I not really able to empty trash (manually or by "empty trash on exit"). When deleting a message from trash, si.mail crashes "An error occurred in the application". Sometimes only one messages in the trash i deleted, and the error shows up.
When disabling "empty trash on exit", I'm still unable to empty, but at least I can leave the program without crashes.

This behavior was taking has place for about the last 10 - 14 days - Perhaps a connection with the last patches from Microsoft, since this is the last time I updated my system ?
Win XP, SP 2, all patches, Danish version.

Any ideas ?

Kind regards, Rolf

mvrhov
Site Admin
Site Admin
Posts: 884
Joined: 12 Jul 2003 21:15
Location: Kranj, Slovenia
Contact:

Re: crash when closing si.mail

Postby mvrhov » 17 Apr 2008 14:57

Hi Rolf,

It seems, that the message IDs in index file and in message file are out of sync. I didn't figure it out what would cause this, but probably file wasn't completely flushed to HDD. Currently there is no option in si.Mail itself to analyze IDs in index file and message and I'm in the middle of components upgrade. I managed to recheck only 30% of forms so you'll have to wait for checker.
Packing files will probably help but it might mess some other messages so I don't recommend it.

Regards,
Miha

mvrhov
Site Admin
Site Admin
Posts: 884
Joined: 12 Jul 2003 21:15
Location: Kranj, Slovenia
Contact:

Re: crash when closing si.mail

Postby mvrhov » 04 Aug 2008 19:07

Hi Rolf,

I figured this one out, it was a nasty one. I'll make official statement when urgent update will be issued in a day or two but for now you can use latest development build. Please don't pack the file if you are still having the ID issue.

Regards,
Miha

mvrhov
Site Admin
Site Admin
Posts: 884
Joined: 12 Jul 2003 21:15
Location: Kranj, Slovenia
Contact:

Re: crash when closing si.mail

Postby mvrhov » 17 Aug 2008 16:58

Hi Rolf,
today's development should have Pack procedure fixed.
If you still have the issue please follow the next steps:
- make backup of messages.dat and message_info.dat
- put si.Mail into offline mode (the world icon on toolbar should have cross on it)
- run Pack on account
- if you get the warning about unrecoverable messages after Pack procedure is done exit si.Mail and restore files from backup and please let me know and I'll try to do some more tweaking of Pack procedure.

Regards,
Miha

rolf
Posts: 83
Joined: 23 Sep 2004 16:19
Location: Denmark

Re: crash when closing si.mail

Postby rolf » 17 Aug 2008 22:42

Hi Miha,

thanks for the new development-version. I will do the testing asap, and tell you about it.

Regarding then problem with the message, I coud not delete form "trash", the solution was quiet simple: I moved it from tras to inbox, and deleted it there again - and it's gone ...
So - sometimes strange things happen :-)

Kind regards, Rolf


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest