January 2010 1.2.x dev

Report bugs here
rolf
Posts: 83
Joined: 23 Sep 2004 16:19
Location: Denmark

January 2010 1.2.x dev

Postby rolf » 05 Jan 2010 21:31

Hi Miha,

just downloaded and installed the latest version :thumbsdown: - sorry to tell you, that it doesn't work at all: no mails / mailviews, no menus (icons), and starts with "an error occurred .."

Sorry to give you more work :-)

Kind regards,
Rolf

mvrhov
Site Admin
Site Admin
Posts: 884
Joined: 12 Jul 2003 21:15
Location: Kranj, Slovenia
Contact:

Re: version siMail_2010-01-05 / 1.2.0.1850

Postby mvrhov » 05 Jan 2010 21:39

Hi Rolf,

any chances of sending or copying the bug report here, if you can get the stack trace.

Regards,
Miha

rolf
Posts: 83
Joined: 23 Sep 2004 16:19
Location: Denmark

Re: version siMail_2010-01-05 / 1.2.0.1850

Postby rolf » 05 Jan 2010 22:30

Hi Miha,

just send it from within si.mail - hope it worked.

I will not be able to see / answer mail before tomorrow late afternoon / evening

Regards, Rolf

mvrhov
Site Admin
Site Admin
Posts: 884
Joined: 12 Jul 2003 21:15
Location: Kranj, Slovenia
Contact:

Re: version siMail_2010-01-05 / 1.2.0.1850

Postby mvrhov » 05 Jan 2010 23:16

Hi Rolf,

Missing theme (exception message : Cannot open file "C:\SiMail 7\Themes\Bluskwairz\". Den angivne sti blev ikke fundet.) is probably the culprit for all further crashes. I'll fix that so in further cases when theme is not found, a default theme would be loaded.

Regards,
Miha

rolf
Posts: 83
Joined: 23 Sep 2004 16:19
Location: Denmark

Re: version siMail_2010-01-05 / 1.2.0.1850

Postby rolf » 06 Jan 2010 06:10

mvrhov wrote:
Missing theme (exception message : Cannot open file "C:\SiMail 7\Themes\Bluskwairz\". Den angivne sti blev ikke fundet.) is probably the culprit for all further crashes. I'll fix that so in further cases when theme is not found, a default theme would be loaded.


Hi Miha,

I saw that error message in the crash-report, but the folder / files are there. Tried even to chance to "C:\SiMail\Themes ... " (default ?), but no success ...

/ Rolf

mvrhov
Site Admin
Site Admin
Posts: 884
Joined: 12 Jul 2003 21:15
Location: Kranj, Slovenia
Contact:

Re: version siMail_2010-01-05 / 1.2.0.1850

Postby mvrhov » 06 Jan 2010 21:19

Hi Rolf,

today's version checks if image file specified in themes definition exists. If it doesn't it will display the file name it searched for and continue loading.

Regards,
Miha

rolf
Posts: 83
Joined: 23 Sep 2004 16:19
Location: Denmark

version 1.2.0.1855

Postby rolf » 08 Jan 2010 09:26

Hi Miha,

with the last version - 1855 I get the following error on starting up (while splash-screen shows "Building favorites tree"), when running, all icons shows as usaual:

"Theme 'Bluskwairz' is declaring the image file named""
We were looking for above image file in:
"C:\SiMail \Themes\Buskwairz\"
Image belongs to Ihe "Main.SectionsToolbar' section.
Toolbar might be incomplete.
OK"

When clicking "OK", the error shows 3 times at all - "Other.Icons" selection, and "Other.Overlay" section

When I chance to Phoenity, it appears only once with "Other.Overlay" section.
(Phoenity is nice, but a bit to colourful for my taste - sorry ... I'v tried to chance all icons in Phoenity to grayscale, but ... )

Not a big deal, since I usually only start up SiMail once in a day and just keep i running, but maybe it can help you finding a bug.

Kind regards,
Rolf

mvrhov
Site Admin
Site Admin
Posts: 884
Joined: 12 Jul 2003 21:15
Location: Kranj, Slovenia
Contact:

Re: January 2010 1.2.x dev

Postby mvrhov » 08 Jan 2010 17:16

Hi Rolf,

I merged all bug posts into one theme, I hope you don't mind :).

If the file name is blank this means, that either there is no section in theme.xml file or there is no file name entered for that section. I removed Bluskwairz theme from the list of si.Mail themes quite a while ago, because it was missing a lot of new icons and there was no maintainer for it. Because you said that you don't like the default one, I recommend that you open theme.xml files from both themes and copy the sections that are missing from default theme into the Bluskwairz then you also need to copy over the image files from default theme. I think this shouldn't be a problem as theme.xml is quite well commented.

Phoenity aka default theme is complete I just checked the si.Mail distribution. please overwrite old si.Mail installation with all files from new one.

Regards,
Miha


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest