Switching profile with different language settings

Report bugs here
papin
Posts: 10
Joined: 13 Jan 2011 18:25

Switching profile with different language settings

Postby papin » 15 Jan 2011 17:39

Hi Miha,

I upgraded version 1.1.0.1770 to 1.2.0.1961.

When I switch to another profile, I got a few times this windowed error message:
The application tried to switch the language, but in an incorrect way. The programmer needs to replace a call to TranslateComponent with a call to RetranslateComponent().
The programmer should see the changelog of gnugettext.pas for more information.

Message appears 5 times after I activate the profile and after entering password.

I tried to repeat that behavior because I didn't give much attention to details. My thoughts:

1- Minor bug because people don't change language very often, do they?
I can imagine them using one profile in English for business and any other language for personal/private messages while at some workplace. But even if I can't read that language I'm not a complete idiot so that I can't tell they're doing personal things instead of working ;)

2- In one profile/config.xml there is not such thing as "<language>xx</language>". In the other profiles, I have "<language>en</language>" and "<language>fr</language>".

3- When I change language, simail says it will restart but it won't. It has to be restarted manually. FYI, simail is NOT installed in "c:\program files\".

4- If I remove "<language>xx</language>" in config.xml, no error message. BUT, if I set a language, "<language>xx</language>" shows up again.

A solution is: set the same language for each profile, close simail, remove "<language>xx</language>" in config.xml within each profile, restart simail. And, of course, do not set any language afterwards.

Or making s.mail restart automatically only if language in new profile is different from currently in use. But feature has to work!

Or "<language>xx</language>" should be definitively removed from profiles as language is relevant only for the user interface (IMHO).
But there is no config file in si.mail's main directory...

mvrhov
Site Admin
Site Admin
Posts: 884
Joined: 12 Jul 2003 21:15
Location: Kranj, Slovenia
Contact:

Re: Switching profile with different language settings

Postby mvrhov » 16 Jan 2011 09:58

Hi,

I think it's going to be easier to forbid switching language when switching profiles as allowing switching language would require a lot of housekeeping to do it properly.

Regards,
Miha

papin
Posts: 10
Joined: 13 Jan 2011 18:25

Re: Switching profile with different language settings

Postby papin » 18 Jan 2011 15:05

Hi Miha,

If you just remove "<language>xx</language>" in profiles/xxx/config.xml and move it to profiles/config.xml, would it solve the problem? To me, looks like you just have to modify 1 line somewhere, and that's it --and no housekeeping as you said.

If I got time, I'll download the source and try to look at it.

And what about the automatic restart of si.mail?


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest